首页 - 入门 - K线 - 新股 - 短线 - 波段 - 买卖点 - 看盘 - 抄底 - 成交量 - 均线 - 分时图 - 名词 - 视频 - 理财 - 创业 - 书籍 - 软件 - 大师 - 佣金 - 手机炒股 - 专题
查看行情
股票代码:
当前位置: > 股票学院 > 公式源码 > 正文

通达信换手解盘指标公式

2011年12月13日   www.chaoguba.com   来源:炒股吧   文字大小:【】【】【

通达信换手解盘指标公式

中盘:FINANCE(7)<1000000000 AND FINANCE(7)>100000000,COLORYELLOW,NODRAW;
小盘:FINANCE(7)<100000000,COLORWHITE,NODRAW;
盘小绩优:FINANCE(7)<1000000000 AND DYNAINFO(39)>0 AND DYNAINFO(39)<=28,COLOR9933FF,NODRAW;
_10日涨跌%:(C-REF(CLOSE,10))/REF(CLOSE,10)*100,COLORGREEN,NODRAW;
{K线部分}
MA3:=MA(C,3);
MA10:=MA(C,10);
MA15:=MA(C,15);
MA21:=MA(C,21);
MA30:=MA(C,30);
VL:=VOL;
V3:=MA(VL,3);
V5:=MA(VL,5);
V13:=MA(VL,13);
V60:=MA(VL,60);
V135:=MA(VL,135);
量比:=V/(REF(MA(V,5),1)),LINETHICK0,COLORRED,NODRAW;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
虚拟量比:=VVOL/(REF(MA(V,5),1)),COLORRED,NODRAW;
获利比%:WINNER(C)*100,COLORLIBLUE,NODRAW;
换手:=VOL/CAPITAL*100, COLORMAGENTA,NODRAW;
十换:=SUM(换手,10),COLORYELLOW,NODRAW;
N:=3;
量能:=SUM(换手,N);
ZL涨幅:=100*(CLOSE-REF(CLOSE,N))/REF(CLOSE,N);
{换手分类}
STICKLINE(C,0,换手*2,2,0),COLOR408080;
STICKLINE(换手<1,1,换手*2,2,0),COLORGREEN;{绿.地量区}
STICKLINE(换手>=1,2,换手*2,2,0),COLORBROWN;{棕.冷门股}
STICKLINE(换手>2,4,换手*2,2,0),COLORLIGRAY;{淡灰.备份股}
STICKLINE(换手>3,6,换手*2,2,0),COLORYELLOW;{黄.热门股}
STICKLINE(换手>5,8,换手*2,2,0),COLORRED;{红.活跃}
STICKLINE(换手>7,10,换手*2,2,0),COLORMAGENTA;{洋红.带量活跃}
STICKLINE(换手>10,12,换手*2,2,0),COLORLIRED;{淡红.放量极活跃}
STICKLINE(换手>15,14,换手*2,2,0),COLORCYAN;{青.巨量险中求}
STICKLINE(换手>25,16,换手*2,2,0),COLORBLUE;{蓝.异常区}
2倍换手%:VOL/CAPITAL*100*2,COLORYELLOW;
十换缩2:SUM(换手,10)/2,COLORLICYAN,LINETHICK2;
{文字位置 }
ZGD:=HHV(十换缩2,60);
ZGD2:=CONST(ZGD);{文字位置 }
DRAWTEXT(CONST(换手<1)AND CURRBARSCOUNT=30,ZGD2,'绿.地量(换<1绝对地量)'),COLORGREEN;
DRAWTEXT(CONST(换手<=2 AND 换手>=1)AND CURRBARSCOUNT=30,ZGD2,'棕.冷清(换1<2,只看不动/属冷门股)'),COLORBROWN;
DRAWTEXT(CONST(换手>2 AND 换手<3)AND CURRBARSCOUNT=30,ZGD2,'淡灰.温和(换2<3,暂无方向/属备份股)'),COLORLIGRAY;
DRAWTEXT(CONST(换手<5 AND 换手>3)AND CURRBARSCOUNT=30,ZGD2,'黄.交投渐活(换3<5,试探介入/属热门股)'),COLORYELLOW;
DRAWTEXT(CONST(换手<7 AND 换手>5)AND CURRBARSCOUNT=30,ZGD2,'红.活跃(换5<7,初步带量/小幅升或落)'),COLORRED;
DRAWTEXT(CONST(换手<10 AND 换手>7)AND CURRBARSCOUNT=30,ZGD2,'洋红.带量(换7<10,大举介入/稳步升或落)'),COLORMAGENTA;
DRAWTEXT(CONST(换手<15 AND 换手>10)AND CURRBARSCOUNT=30,ZGD2,'淡红.放量(换10<15,重点关注/大幅升或落)'),COLORLIRED;
DRAWTEXT(CONST(换手<25 AND 换手>15)AND CURRBARSCOUNT=30,ZGD2,'青.巨量(换15<25,短进中清仓/提防暴跌)'),COLORCYAN;
DRAWTEXT(CONST(换手>=25)AND CURRBARSCOUNT=30,ZGD2,'蓝.异常(换>25,强势涨高点不远/不强势涨大跌在即)'),COLORBLUE;
{DRAWTEXT(CONST(量能>3*N AND 涨幅1>3*N)AND CURRBARSCOUNT=30,15,'继续大涨!'),COLORLIGRAY;
DRAWTEXT(CONST(量能<0.5*N AND 涨幅1<N )AND CURRBARSCOUNT=30,10,'继续小涨!'),COLORLIGRAY;
DRAWTEXT(CONST(量能<0.5*N AND 涨幅1>-N AND 涨幅1>0 )AND CURRBARSCOUNT=30,ZGD2*0.9,'量能不配合,继续小跌!'),COLORLIGRAY;
DRAWTEXT(CONST(量能>3*N AND 涨幅1<-3*N)AND CURRBARSCOUNT=30,ZGD2*0.9,'量能不理想,继续大跌!)'),COLORLIGRAY; }
DRAWTEXT(CONST((量能>3*N AND ZL涨幅<N) OR (量能<0.5*N AND ZL涨幅>3*N)
OR (量能>3*N AND ZL涨幅>-N AND ZL涨幅<0) OR (量能<0.5*N AND ZL涨幅<-3*N))AND CURRBARSCOUNT=30,ZGD2*0.9,'注意反转!)'),COLORLIGRAY;
{最上直线方块20换和十均换 }
STICKLINE(SUM(V/CAPITAL*100,20)>80,ZGD2*1.1,ZGD2*1.12,2,0),COLORYELLOW;{黄.20换>80 }
STICKLINE(SUM(V/CAPITAL*100,10)/10>3,ZGD2,ZGD2*1.02,2,0),COLORWHITE;{白.十均换>3/有庄家,高抛低吸 }
STICKLINE(SUM(V/CAPITAL*100,10)/10>5,ZGD2,ZGD2*1.02,2,0),COLORRED; {红.十均换>5/庄家强势 }
{0轴下方框.量比和起涨点}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
DIF趋势:=DEA>REF(DEA,1);
DIF趋势2:=DEA<REF(DEA,1);
M5:=MA(CLOSE,5);
A1:=M5>=MA10 OR CROSS(M5,MA10) OR (C>MA10 AND MA10>M5);
涨幅%:=(C-REF(C,1))/REF(C,1)*100,LINETHICK0;
换手率%:=VOL/CAPITAL*100*2,COLORYELLOW;
换手率%1:=换手率%>5;
量比1:=量比>1.5 OR 虚拟量比>1.5;
获利比例%1:=获利比%>70;{筹码有较好的集中还要区别是筹码低位集中,还是高位集中 }
涨幅%1:=涨幅%>3;
启动:=换手率%1 AND 量比1 AND 获利比例%1 AND 涨幅%1 AND A1 AND K<60 AND DIF趋势 ;
爆涨点:=IF(启动,60,0)COLORWHITE,LINETHICK1;
启动2:=换手率%1 AND 量比1 AND 获利比例%1 AND 涨幅%1 AND A1 AND (K>70 OR DIF趋势2) ;
量能顶:=IF(启动2,60,0)COLORWHITE,LINETHICK1;
STICKLINE(FILTER(爆涨点=60,3),-0.5,-4,2,0),COLORRED;{红.爆涨点}
STICKLINE(FILTER(量能顶=60,3),-0.5,-4,2,0),COLORGREEN;{绿.量能顶}
STICKLINE(量比>1,-0.5,-1.5,1,1),COLORGRAY;{灰.量比>1 }
STICKLINE(量比>2,-0.5,-1.5,1,1),COLORCYAN;{青.量比>2 }
{0轴下下为波段信号}
{黄金反弹 }
RSVH:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KKKH:=SMA(RSVH,3,1),COLORWHITE;
DDDH:=SMA(KKKH,3,1),COLORYELLOW ;
BIAS1:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
AA1H:=CROSS(KKKH,DDDH) AND CROSS(KKKH,DDDH)<16 AND BIAS1<-6;
K1H:=IF(KKKH>DDDH,6,0);
D1H:=IF(DDDH>KKKH,4,0);
黄金反弹:=IF(AA1H,40,0),COLORFF00FF;
{底下小方块为短线走势强弱信号}
STICKLINE(黄金反弹=40,-2,-4,2.1,0),COLORYELLOW;{黄背柱抢反弹 };
{主力进场 }
N1:=9;
N2:=5;
MTM:=C-REF(C,1);
ZLGJ:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),COLORWHITE;
MAZL:=MA(ZLGJ,N2),COLORYELLOW;
主力进:=ZLGJ>REF(ZLGJ,1) OR ZLGJ>MAZL;
主力强势:=ZLGJ>0;
{主升 }
均价:=(HIGH+LOW+CLOSE)/3;
个股趋势:=SMA(((均价-LLV(均价,28))/(HHV(均价,28)-LLV(均价,28))*100),3,1),COLORYELLOW;
{综合度 ; 秀山腾龙 ; TDX版}
DEA度:=IF(DEA>REF(DEA,1) AND DEA>0,2,IF(DEA>REF(DEA,1) AND DEA<0,1,0));
DIFF度:=IF(DIFF>DEA AND DEA>REF(DEA,1) AND DIFF>REF(DIFF,1),1,IF(DIFF>DEA AND DEA>REF(DEA,1) AND DIFF<REF
(DIFF,1),0.5,0));
MACD度:=IF(MACD>REF(MACD,1) AND MACD>0,1,IF(MACD>REF(MACD,1) AND MACD<0,0.5,0));
M度:=DEA度+DIFF度+MACD度;
V35:=MA(V,35);
五日量:=SUM(V,5);
均量度:=IF(V>35 AND V35>REF(V35,1),2,IF(V<V35 AND V35>REF(V35,1),1,0));
增量度:=IF(五日量>REF(五日量,1),1,0);
量度:=均量度+增量度;
TRR:=SMA(MAX(MAX(H-L,ABS(H-REF(C,1))),ABS(L-REF(C,1))),14,1);
HDD:=H-REF(H,1);
LDD:=REF(L,1)-L;
DMP:=SMA(IF(HDD>0 AND HDD>LDD,HDD,0),6,1);
DMM:=SMA(IF(LDD>0 AND LDD>HDD,LDD,0),6,1);
PDI:=DMP*100/TRR;
MDI:=DMM*100/TRR;
PDI度:=IF(PDI>REF(PDI,1) AND PDI>MDI,1,IF(PDI>REF(PDI,1) AND PDI<MDI,0.5,0));
MDI度:=IF(MDI<REF(MDI,1) AND MDI<PDI,1,IF(MDI<REF(MDI,1) AND MDI>PDI,0.5,0));
DMI度:=PDI度+MDI度;
综合度:=M度+量度+DMI度,COLORCYAN,NODRAW;
走强:=IF(综合度>=5,综合度,0);
走弱:=IF(综合度<5,综合度,0);
强势线:=SMA(走强,3,1)*10,COLORYELLOW,DOTLINE;
弱势线:=SMA(走弱,3,1),COLORGREEN,;
{启动追涨}
QQ:=(((((MA(CLOSE,1) + MA(CLOSE,3)) + MA(CLOSE,5)) + MA(CLOSE,7)) + MA(CLOSE,9)) / 5);
WWD:=(((((MA(CLOSE,2) + MA(CLOSE,4)) + MA(CLOSE,6)) + MA(CLOSE,8)) + MA(CLOSE,10)) / 5);
AQ:=EMA(QQ,3);
BQ:=EMA(WWD,10);
VAR1Q:=EMA(AMOUNT,1)/EMA(VOL,1)/100;
AAQ:=DMA(AQ,VAR1Q);
BBQ:=DMA(BQ,VAR1Q);
VAR29Q:=MAX((2*(AAQ-BBQ)),0)*100;
拉升线:=EMA(VAR29Q,3),COLORFFFFFF,LINETHICK2;
MAD:=DIFF>REF(DIFF,1);
VAR2GD:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
做多能量:=SMA(VAR2GD,5,1),LINETHICK2,COLORRED;
MAV:=(2*C+H+L)/4;
VAR1D:=LLV(LOW,34);
VAR2D:=HHV(HIGH,34);
SK:= EMA((MAV-VAR1D)/(VAR2D-VAR1D)*100,13);
SD:= EMA(0.667*REF(SK,1)+0.333*SK,2);
M11:=MA(C,10);
M1:=M11>REF(M11,1);
MD:=SD>REF(SD,1);
个股趋势2:=个股趋势>REF(个股趋势,1);
{www.gUPaNg.com 股旁网_最新股票指标公式}
主升:=拉升线>REF(拉升线,1)OR 个股趋势2 OR 强势线>REF(强势线,1)AND 做多能量>REF(做多能量,1)AND MD AND M1 AND MAD;
STICKLINE(主力进,-2.5,-3.5,4,0),COLORRED;{0轴下红/主力进 }
STICKLINE(ZLGJ<REF(ZLGJ,1) OR ZLGJ<MAZL,-2.5,-3.5,4,0),COLOR00FF00;{0轴下绿/主力出 }
STICKLINE(主升,-2.5,-3.5,0.5,0),COLORYELLOW;{0轴下黄/主力强升};
{梦的海洋10 /换手率状态看强庄 }
量能饱和:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW,COLORWHITE;
{【十九强】:量价角度定强弱;}
MV3:=EMA(V,3);
M3:=EMA(C,3);
MV3角度:=ATAN((MV3/REF(MV3,1)-1)*100)*180/3.1416;
MA3角度:=ATAN((M3/REF(M3,1)-1)*100)*180/3.1416;
MV5:=EMA(V,5);
MA5:=EMA(C,5);
MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
MV10:=EMA(V,10);
M10:=EMA(C,10);
MV10角度:=ATAN((MV10/REF(MV10,1)-1)*100)*180/3.1416;
MA10角度:=ATAN((M10/REF(M10,1)-1)*100)*180/3.1416;
强弱度1:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF,NODRAW;
强弱度:=MA(强弱度1,3),COLORCYAN,NODRAW;
STICKLINE(量能饱和>30 AND 强弱度>1 AND C>MA(C,5) OR C>MA(C,10),换手*2,十换缩2,0.5,1),COLORMAGENTA;{洋红柱.量能饱和区}
STICKLINE(十换缩2>20/2,十换缩2*0.98,十换缩2,2,0),COLORWHITE;{十换线上黄点.有庄家可做高抛低吸 }
STICKLINE(十换缩2>60/2,十换缩2*0.98,十换缩2,2,0),COLORRED; {十换线上红点.强势股 };
{量价齐升解盘}
B:=SMA((3*H+2*C+O+L)/7,10,1);
W1:=-100*(HHV(HHV(B,1),13)-B)/(HHV(HHV(B,1),13)-LLV(LLV(B,1),13));
W2:=-100*(HHV(HHV(B,1),34)-B)/(HHV(HHV(B,1),34)-LLV(LLV(B,1),34));
W3:=-100*(HHV(HHV(B,1),55)-B)/(HHV(HHV(B,1),55)-LLV(LLV(B,1),55));
W4:=-100*(HHV(HHV(B,1),5)-B)/(HHV(HHV(B,1),5)-LLV(LLV(B,1),5));
价格WR:=(W1+W2+W3+W4)/4;
A:=SMA(VOL,10,1);
WR1:=-100*(HHV(HHV(A,1),13)-A)/(HHV(HHV(A,1),13)-LLV(LLV(A,1),13));
WR2:=-100*(HHV(HHV(A,1),34)-A)/(HHV(HHV(A,1),34)-LLV(LLV(A,1),34));
WR3:=-100*(HHV(HHV(A,1),55)-A)/(HHV(HHV(A,1),55)-LLV(LLV(A,1),55));
WR4:=-100*(HHV(HHV(A,1),5)-A)/(HHV(HHV(A,1),5)-LLV(LLV(A,1),5));
量WR:=(WR1+WR2+WR3+WR4)/4;
WR:=-100*(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55));
多空平衡:=-50;
MA55:=MA(C,55);
MA1:=MA(VOL,5);
DRAWTEXT((CONST(IF(CLOSE>=MA(CLOSE,13),1,0))) AND CURRBARSCOUNT=60,ZGD2*1.25,'●短持股'),COLORRED;
DRAWTEXT((CONST(IF(CLOSE<MA(CLOSE,13) AND C<MA(CLOSE,5),1,0))) AND CURRBARSCOUNT=60,ZGD2*1.25,'●短持币'),COLORGREEN;
DRAWTEXT(CONST(REF(价格WR,3) AND REF(价格WR,1)<价格WR) AND CURRBARSCOUNT=55,ZGD2*1.25,'●量价转多;'),COLORRED;
DRAWTEXT(CONST(REF(价格WR,3)>REF(价格WR,2) AND REF(价格WR,2)>REF(价格WR,1) AND REF(价格WR,1)>价格WR)
AND CURRBARSCOUNT=55,ZGD2*1.25,'●量价转空;'),COLORFF00FF;
DRAWTEXT(CONST(价格WR=-100)AND CURRBARSCOUNT=50,ZGD2*1.25,'●量价很弱不碰!'),COLORFF00FF ;
DRAWTEXT((CONST(V5>REF(V5,1)*1.015)) AND CURRBARSCOUNT=60,ZGD2*1.1,'●5量线强劲向上;'),COLORYELLOW;
DRAWTEXT((CONST(V3>V60)) AND CURRBARSCOUNT=53,ZGD2*1.1,'●3量线>60量线!'),COLORYELLOW;
DRAWTEXT((CONST(CROSS(V5,V35))) AND CURRBARSCOUNT=46,ZGD2*1.1,'●今日V5金叉V35;'),COLORYELLOW;
DRAWTEXT((CONST(CROSS(V5,V135))) AND CURRBARSCOUNT=39,ZGD2*1.1,'●今日V5金叉V135;'),COLORYELLOW;

(责任编辑:admin)
郑重声明:炒股吧网发布此信息出于传递更多信息之目的,不表明证实其描述或赞同其观点。本站不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。
关于炒股吧 - 法律申明 - 网站律师 - 合作伙伴 - 广告服务 - 诚聘英才 - 征稿启事 - 联系方式 - 意见反馈 - 友情连接 - 网站地图
Copyright©2007-2016 炒股吧 chaoguba.com All Rights Reserved 版权所有 复制必究

特别声明:本站所载文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负。