首页 - 入门 - K线 - 新股 - 短线 - 波段 - 买卖点 - 看盘 - 抄底 - 成交量 - 均线 - 分时图 - 名词 - 视频 - 理财 - 创业 - 书籍 - 软件 - 大师 - 佣金 - 手机炒股 - 专题
查看行情
股票代码:
当前位置: > 股票学院 > 公式源码 > 正文

通达信换手率源码公式

2011年12月13日   www.chaoguba.com   来源:炒股吧   文字大小:【】【】【

通达信换手率源码公式

换手率公式:DRAWGBK(1, COLORRGB(100,100,100),COLORRGB(50,50,50),0);
{换手100%}
svol:=INTPART(SUM(V,0)/CAPITAL);
tj0:=svol>REF(svol,1) or BARSSINCE(CLOSE)=0;
S1:=BARSLAST(tj0)+1,PRECISION,COLORWHITE;//时间1
tj2:=S1<ref(S1,1);//取点
S2:=if(tj2,ref(S1,1)+1,S1),PRECISION,COLORMAGENTA;//时间2
S3:=sum(tj2,0),COLORMAGENTA;
阶段总额(万元):=SUM(AMOUNT/10000,S2)*100,PRECISION,LINETHICK,Color008BFA;//换手100%成交额
阶段总量(手):=SUM(V,S2)*100,PRECISION,LINETHICK,COLORCYAN;//换手100%成交量
阶段成本(元):=(阶段总额(万元)/(阶段总量(手)/100)),LINETHICK,PRECISION2,COLORRED;
DRAWTEXT(BARPOS=SYSPARAM(2),h,/■阶段平均成本:/+NUMTOSTR(阶段成本(元)[SYSPARAM(1)],2)+/(元)/),align4,COLORCYAN;
//
{取点}
Zk1:=STKINDI(// ,/kdj.k/,0,7);
Zd2:=STKINDI(// ,/kdj.d/,0,7);
ZF1:=STKINDI(// ,/macd.diff/,0,7);
ZA2:=STKINDI(// ,/macd.dea/,0,7);

{------------------☆功能开关--------------------}
{建仓统计}
换手率:v/FINANCE(7),LINETHICK,PRECISION2,COLORCYAN;{换手率}
JCD:=FILTER(CROSS(Zk1,Zd2)&&Zd2<30,13);{周KD金叉位置}
取点:=barslast(JCD);
吸筹区:=if(取点>0 and 取点<61,取点,0);
ZS1:=吸筹区;
ZS2:=吸筹区+1;
ZS3:=换手率/5;{庄家筹码估算}
ZSA:=IF(ZS1>0,sum((ZS3),吸筹区+1),0);{统计庄家筹码}
{控制画线高度}
n1:=sysparam(3);
nn:=n1-sysparam(2)+1;
hh:=hhv(换手率,nn);
ll:=llv(换手率,nn);
最高:=hh[n1];
最低:=ll[n1];
中:=最低+(最高-最低)*0.5;

{-----------------【图解模板】---------------------}
{换手率}
换手冷清:STICKLINE(换手率<3,0,换手率,4,1),COLORWHITE;//冷清
换手活跃:STICKLINE(换手率>=3 and 换手率<7,0,换手率,4,1),COLORYELLOW;//活跃
换手热烈:STICKLINE(换手率>=7,0,换手率,4,1),COLORRED;//热烈
{换手MA}
PARTLINE(C,MA(换手率,13)),Color0089FF;
PARTLINE(C,MA(换手率,55)),COLOR009900;

PARTLINE(RANGE(BARPOS,SYSPARAM(2),SYSPARAM(1)+1)&&ZS1>0,中),COLORCYAN;//建仓横线
VERTLINE(JCD),LINEDOT,COLORGREEN;//建仓点竖线
DRAWTEXT(BARSCOUNT(C)=SYSPARAM(1)& amp;&SYSPARAM(1)>ZS1,中*2,/   主力建仓天数:/+NUMTOSTR(ZS1[SYSPARAM(1)],0)+/(天) /),PXDN30,align2,COLORGREEN;
DRAWTEXT(BARSCOUNT(C)=SYSPARAM(1)& amp;&SYSPARAM(1)>ZS1,中*2,/ \n 估算主力筹码:/+NUMTOSTR(ZSA[SYSPARAM(1)],2)+/% /),PXDN30,align2,COLORMAGENTA;
DRAWICON(FILTER(CROSS(ZF1,ZA2),5),0,4),align5;
DRAWICON(FILTER(CROSS(Zk1,Zd2),5),0,8),align5;
DRAWICON(FILTER(CROSS(Zd2,Zk1),5),0,9),align5;

(责任编辑:admin)
郑重声明:炒股吧网发布此信息出于传递更多信息之目的,不表明证实其描述或赞同其观点。本站不保证该信息(包括但不限于文字、数据及图表)全部或者部分内容的准确性、真实性、完整性、有效性、及时性、原创性等。相关信息并未经过本网站证实,不对您构成任何投资建议,据此操作,风险自担。
关于炒股吧 - 法律申明 - 网站律师 - 合作伙伴 - 广告服务 - 诚聘英才 - 征稿启事 - 联系方式 - 意见反馈 - 友情连接 - 网站地图
Copyright©2007-2016 炒股吧 chaoguba.com All Rights Reserved 版权所有 复制必究

特别声明:本站所载文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负。